Le toco un sencillo (y largo) proceso de Downgrade a la MacBook con la que estoy trabajando tras haberse pasado algunos meses utilizando MacOS BigSur. ¡De eso hablare más adelante!

Lo importante es que al retomar algunos proyectos, al hacer un pod install para poder instalar las dependencias en el proyecto para iOS enviaba el siguiente error:

Leyendo varios foros encontré que en algún momento la el path de instalación de XCode fue modificado y por lo tanto React Native no lo podía localizar.

La solución queda de la siguiente manera, ejecutando el siguiente comando en la terminal más cercana:

$ sudo xcode-select --switch /Applications/Xcode.app

¡Y listo! Pudimos continuar con las actividades de desarrollo 😉